Cloudflare Global Network experiencing issues

Incident Report for Easy Tec Status

Resolved

It seems as though the error has finally been fixed.
Posted Nov 18, 2025 - 16:29 CET

Monitoring

A fix for the problem has been developed by Cloudflare and is currently being tested.
Posted Nov 18, 2025 - 15:42 CET

Update

Cloudflare experiencing global network issues. See more: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 14:48 CET

Identified

Cloudflare has some issues. See more: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 12:52 CET

Investigating

We identified some errors on our services and still investigate.
Posted Nov 18, 2025 - 12:48 CET
This incident affected: Application Server (Website (ETS), Website Analytics, Cloud (PROD), Cloud (BETA)).