⚠️ Email service outage - Adjusting email forwarding

Incident Report for Easy Tec Status

Resolved

The changeover appears to have been successful.
All services should be functioning normally again.
Posted Dec 19, 2025 - 16:23 CET

Update

Everything seems to be working as expected.
Therefore, final adjustments have been made, which will now be monitored over the next 24 hours.
Posted Dec 18, 2025 - 21:45 CET

Monitoring

The changeover has already taken place, and the final change will be made tomorrow (December 18, 2025). Email communication should now be possible, but we recommend that you continue to use the contact form to get in touch with us over the next two days. https://easytec.tech/en/contact
Posted Dec 17, 2025 - 17:31 CET

Identified

Emails are currently not being forwarded.
If you need to contact us urgently, please do so using our contact form at https://easytec.tech/en/contact. Otherwise, please wait until December 18, 2025. Thank you for your understanding.
Posted Dec 16, 2025 - 22:01 CET
This incident affected: Infrastructure (Email Routing).