🚧 Domain Migration

Incident Report for Easy Tec Solutions

Update

The move has now been finalized and will take place by September 6, 2026. Please note that after September 6, 2026, all services and email addresses will no longer be accessible via their old addresses. It is quite possible that domains and email addresses on websites will be updated as early as this date. Please stay informed. One option is to subscribe to updates on this matter; you will then receive an email whenever a change is made.
Posted Aug 09, 2026 - 18:59 CEST

Identified

We are currently reviewing a possible change to our domain and email addresses in order to improve our services. As soon as the changes are finalized, we will notify you in a timely manner here, on our website, and (if known) via email.
Posted Jul 27, 2026 - 17:17 CEST