⚠️ Possible Performance Issues

Incident Report for Easy Tec Solutions

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 11:30 CEST

Investigating

At this time, we cannot rule out the possibility of occasional issues with the availability of our services. We are working to resolve any current outages and confirm that our services are functioning properly.
Posted Aug 31, 2026 - 23:11 CEST
This incident affected: Infrastructure (Network) and Application Server (Website (ETS), Website Analytics, Cloud (PROD), Cloud (BETA)).