Emails are currently not being forwarded. If you need to contact us urgently, please do so using our contact form at https://easytec.tech/en/contact. Otherwise, please wait until December 18, 2025. Thank you for your understanding.
Posted Dec 16, 2025 - 21:47 CET
Update
Start with redirection.
Posted Dec 16, 2025 - 21:16 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 16, 2025 - 21:00 CET
Scheduled
Current maintenance work on our email system will cause a brief interruption in email traffic. If you would like to contact us, please use the contact form on our website: https://easytec.tech/en/contact
Posted Dec 16, 2025 - 17:30 CET
This scheduled maintenance affected: Infrastructure (Email Routing).